Note: While our most popular guides have been translated into Spanish, some guides are only available in English.
TLS protocols update

We're upgrading protocols we use to keep your Squarespace account secure, prevent vulnerabilities, and maintain compliance with the PCI Data Security Standard.

Starting June 30, 2018, the PCI Council is requiring companies like Squarespace that use Transport Layer Security (TLS) to upgrade to version 1.2 for all HTTPS connections. This means we're going to stop using earlier versions (1.0 and 1.1).

Will Squarespace be compliant?

Yes. All of Squarespace—including our built-in tools and payment processors—will meet the new TLS protocol standards by June 30, 2018.

To learn more about our security standards, visit PCI-DSS compliance.

Do I need to do anything?

Squarespace services will update automatically to comply with this change. To ensure a secure connection to your Squarespace site, set your operating system and browsers to update automatically, so you’re always using the latest available version of a supported browser. Some features on your site, like checkout or images, might not work or load correctly on older browsers.

If you have general PCI-DSS compliance questions, please contact your payment processor:

Was this article helpful?
8 out of 12 found this helpful